Downloads

ChatGpt.tcl

€10.00

++ Minimum python requirement : 3.8++ Put the chatgpt key in OpenAIChatAPI.py++ OpenAIChatAPI.py must run in background in order for the TCL to work.++ Use "python3 OpenAIChatAPI.py &" command (without commas) to run it in background++ The OpenAIChatAPI.py should install all necessary packages (flas...
user-avatar

Author: BLaCkShaDoW
Version: 1.0
Added: 2024-05-31
Last Updated: 2024-06-05

Description

++ Minimum python requirement : 3.8
++ Put the chatgpt key in OpenAIChatAPI.py
++ OpenAIChatAPI.py must run in background in order for the TCL to work.
++ Use "python3 OpenAIChatAPI.py &" command (without commas) to run it in background
++ The OpenAIChatAPI.py should install all necessary packages (flask, openai)
++ Load the ChatGpt.tcl in the eggdrop
++ Enable the script with the command .set +openai or .chanset #channel +openai
++ Finally, talk with the eggdrop by specifying it's nickname
++ Have Fun:-)
++ If installation is successful but the python script gives error you may need to buy some credits from openai.

Example

[16:54] <@BLaCkShaDoW> TCLHelp who are you ?
[16:54] <@TCLHelp> I am a language model AI assistant here to help and provide information on a wide range of topics. How can I assist you today?
[16:57] <@BLaCkShaDoW> TCLHelp do you know the future ?
[16:57] <@TCLHelp> As an AI, I do not have the ability to predict the future with certainty. The future is uncertain and influenced by a multitude of factors. It is important to approach the future with an open mind and adaptability to whatever may come.

5 Reviews for ChatGpt.tcl

cristian.manta67802
salut Am instalat totul dar primesc eroare 500 dece?
Rain
Am instalat totul cum trebuie, si nu imi merge chatgpt, ma puteti ajuta cumva ?
BLaCkShaDoW
Ai pus key și rulat scriptul de Python pe server?
Rain
Vorbeste si in Romana?
Mitzi
it works very good!! very nice and simple to use.

Add a review

Your Rating

69536

Character Limit 400