Forum

Brainyquote.tcl
 
Notifications
Clear all

[Solved] Brainyquote.tcl


asL pLs
(@aslpls)
Active Member
Joined: 8 months ago
Posts: 15
Topic starter  

just purchased the brainyquote.tcl.. install in my bot.. 

 

then when i type in the channel !bq  !bq life

 

this is the error in dcc chat:

 

[12:07:25] Tcl error [brainy:quote]: invalid command name "http::register"

This topic was modified 2 weeks ago by asL pLs

Quote
BLaCkShaDoW
(@blackshadow)
Member Admin
Joined: 9 months ago
Posts: 73
 

Load http.tcl before the brainyquote.tcl


ReplyQuote
asL pLs
(@aslpls)
Active Member
Joined: 8 months ago
Posts: 15
Topic starter  

i have added the http.tcl .. but i have issues with this tls

 

[14:54:59] Tcl error [brainy:quote]: wrong # args: should be "tls::socket ?options? host port"

 

 

how to fix this..


ReplyQuote
BLaCkShaDoW
(@blackshadow)
Member Admin
Joined: 9 months ago
Posts: 73
 

read in tcl, you need http.tcl and tls package installed.


ReplyQuote
asL pLs
(@aslpls)
Active Member
Joined: 8 months ago
Posts: 15
Topic starter  

[15:39:53] Tcl error [brainy:quote]: invalid command name "::tls::socket"

 

 

i update my tcl and tls ang put http .. still the same..

Tcl library: /usr/share/tcltk/tcl8.6
Tcl version: 8.6.9 (header version 8.6.9)

TLS 1.7.16 version..

 

 

what to do..

 

 

This post was modified 2 weeks ago by asL pLs

ReplyQuote
BLaCkShaDoW
(@blackshadow)
Member Admin
Joined: 9 months ago
Posts: 73
 

As i said, ::tls::socket is a procedure from tls package. Its used to register https 443. If it doesnt exist you dont have it installed. Its simple. check other tcl that requires tls package.


ReplyQuote
Time Rider
(@timerider)
New Member
Joined: 2 weeks ago
Posts: 4
 

Hello asL pLs, Which linux OS are you using? If you could tell the OS version too? I could help you with some links to install tls package for eggdrop.

 

BLaCkShadoW is right, the package isn't installed properly.


ReplyQuote
asL pLs
(@aslpls)
Active Member
Joined: 8 months ago
Posts: 15
Topic starter  
xXX

 

i have loaded other scripts... 

example: youtube.tcl that requires 

package require json
package require http
package require tls

and it is working fine.. no issue..

 

example: weather.tcl

package require json
package require http
package require tdom

 

and it is working fine.. no issue..

 

now.. for the brainyquote.tcl

 

everything set in the channel.. but then when you type the command !bq this is the issue

-------------

[02:34:53] Tcl error [brainy:quote]: wrong # args: should be "tls::socket ?options? host port"

------------------------------

 

 

@Time Rider: i am using Debian GNU/Linux 9.13

 

 

 

This post was modified 2 weeks ago by asL pLs

ReplyQuote
BLaCkShaDoW
(@blackshadow)
Member Admin
Joined: 9 months ago
Posts: 73
 

You need latest tls package (1.7.xx) like 1.7.18 or 1.7.20 you have 1.6.17.


ReplyQuote
asL pLs
(@aslpls)
Active Member
Joined: 8 months ago
Posts: 15
Topic starter  
Posted by: @aslpls

[15:39:53] Tcl error [brainy:quote]: invalid command name "::tls::socket"

 

 

i update my tcl and tls ang put http .. still the same..

Tcl library: /usr/share/tcltk/tcl8.6
Tcl version: 8.6.9 (header version 8.6.9)

TLS 1.7.16 version..

 

 

what to do..

 

 

Here's my latest setup...


ReplyQuote
asL pLs
(@aslpls)
Active Member
Joined: 8 months ago
Posts: 15
Topic starter  

<asL_pLs>!bq

<botname> -= Brainy Quote =-
<Botname> (William Temple) "When I pray, coincidences happen, and when I don't, they don't."

  • <@asL_pLs> !bq rich young
    <botname> -= Brainy Quote =- for "rich young"
    <botname> (<div class="qbn-box">) "Why should only rich men have young, beautiful women? Rich women should have young, beautiful men."

 

now need help to this..


ReplyQuote
BLaCkShaDoW
(@blackshadow)
Member Admin
Joined: 9 months ago
Posts: 73
 

Check mail for the fixed version.


ReplyQuote
asL pLs
(@aslpls)
Active Member
Joined: 8 months ago
Posts: 15
Topic starter  

thank you. got it.


ReplyQuote
Share: