Forum

Suggestions
 
Notifications
Clear all

Suggestions


rain nap
(@kcabmask)
Eminent Member
Joined: 12 months ago
Posts: 22
Topic starter  

Hi i noticed that the statistics will give only the current month. It would be nice if it will include an option to include statistics from previous month/years. I have also notice that it will not accept answer with extra spaces. If this is easy fix can you provide some patch to strip down automatically whitespaces for the answer? 


Quote
BLaCkShaDoW
(@blackshadow)
Member Admin
Joined: 1 year ago
Posts: 97
 

Hello, the option to include months and years is saved and it will be included into the next version. Related to strip down the whitespaces, i apply this patch and anounce here. Then you can download it again from Account -> Purchase history.


ReplyQuote
BLaCkShaDoW
(@blackshadow)
Member Admin
Joined: 1 year ago
Posts: 97
 

Download it again and replace BlackTrivia.tcl (remember to replace all the settings with your settings from old BlackTrivia.tcl.


ReplyQuote
rain nap
(@kcabmask)
Eminent Member
Joined: 12 months ago
Posts: 22
Topic starter  

I tried it but it seems not working. for example the answer to the question is "five" and you type " five" or "five " , with a space before five or with a space after five it does not accept the answer. 


ReplyQuote
BLaCkShaDoW
(@blackshadow)
Member Admin
Joined: 1 year ago
Posts: 97
 

Download it again.


ReplyQuote
rain nap
(@kcabmask)
Eminent Member
Joined: 12 months ago
Posts: 22
Topic starter  

Can you confirm if this is working for you? Its not working on me.


ReplyQuote
BLaCkShaDoW
(@blackshadow)
Member Admin
Joined: 1 year ago
Posts: 97
 

check in BlackTrivia.tcl in process:

proc trivia:get_answer {nick host hand chan arg} {

you will have 

 set answer [string trimright [trivia:color_filter [lrange [split $arg] 0 end]] " "]

Check if this is your line there, line 3913, if this is the line, it should work. If not, replace your line with this one.

 


ReplyQuote
rain nap
(@kcabmask)
Eminent Member
Joined: 12 months ago
Posts: 22
Topic starter  

I check that line. It was there. < 123> doesn't accept <123 > doesn't accept. <123> it works

 Screen Shot 2020 11 13 at 11.46.42 PM

ReplyQuote
asL pLs
(@aslpls)
Eminent Member
Joined: 1 year ago
Posts: 25
 

@blackshadow

 

make it soon bro..  😀  .. with monthly / years /  that is a very nice features


ReplyQuote
Share: